JG Vimalan's Blog

It is all about coding!

Android requires .class compatibility set to 5.0. Please fix project properties

I got this error message when I created my first android application. Right after creating the application, when I tried to run, the error message was displayed. I fixed this error message by selecting the android sdk version in the java build path. That is, select the project and goto its properties. Select Java Build Path, check the android sdk version in the ‘order and export’ tab. See the image below,

this will fix the error message. Now you will be able to run your android application.


Advertisements

October 27, 2010 - Posted by | Android

2 Comments »

  1. Pretty good post. I just stumbled upon your blog and wanted to say that I have really enjoyed reading your blog posts

    Comment by Christina | February 6, 2011 | Reply

  2. It worked! thanks a lot for providing this solution.

    Comment by Yuvraj | February 25, 2011 | Reply


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: